> 当我们需要在命令行下访问并运行框架的时候,我们需要了解以下内容: > 运行的php版本必须大于5.3 > 管理员模式下运行 >下面以windows下为例: >1.首先将目录切换到web下:![](https://box.kancloud.cn/4bdc21c5bd2ace36a694be6bc07a3be6_664x38.png) >2.然后运行index.php![](https://box.kancloud.cn/cf42080ab71ebddc1ef3d5da040054ad_618x44.png) >如果打印出`hello this is cli mode,framework version:2.3.0`字样表示运行成功 >3.访问指定控制器需要附加参数进行指定,例如我需要运行`Home/http/spider`则可以这么输入:![](https://box.kancloud.cn/0065af121cf0c98e473985e51140b456_698x40.png) >![](https://box.kancloud.cn/746054474840842ba0f8ad040018df52_355x208.png) >每个参数之间用空格隔开 >[点击这里查看解决乱码问题](http://ldgliguang.blog.163.com/blog/static/818458201303111452568/)